LibOFX

From CBLFS
Jump to: navigation, search
Download Source: http://downloads.sourceforge.net/libofx/libofx-0.9.0.tar.gz
Optional Patch : http://svn.cross-lfs.org/svn/repos/patches/libofx/libofx-0.9.0-gcc4.3-1.patch

Contents

Introduction to LibOFX

LibOFX is a generic library to allow financial software to easily support the Open Financial eXchange specification. It can be used with financial programs such as GnuCash and KMyMoney.

Project Homepage: http://libofx.sourceforge.net/

Dependencies

Required

Recommended

Optional

Non-Multilib

If you have gcc4.3, apply this patch :

patch -Np1 -i ../libofx-0.9.0-gcc4.3-1.patch

Compile the package:

./configure --prefix=/usr &&
make

Install the package

make install

Multilib

32Bit

If you have gcc4.3, apply this patch :

patch -Np1 -i ../libofx-0.9.0-gcc4.3-1.patch

Compile the package:

CC="gcc ${BUILD32}" CXX="g++ ${BUILD32}" \
PKG_CONFIG_PATH="$PKG_CONFIG_PATH32}" USE_ARCH=32 \
./configure --prefix=/usr &&
make

Install the package:

make install

N32

If you have gcc4.3, apply this patch :

patch -Np1 -i ../libofx-0.9.0-gcc4.3-1.patch

Compile the package:

CC="gcc ${BUILDN32}" CXX="g++ ${BUILDN32}" \
PKG_CONFIG_PATH="$PKG_CONFIG_PATHN32}" USE_ARCH=n32 \
./configure --prefix=/usr --libdir=/usr/lib32 \
    --with-opensp-libs=/usr/lib32 &&
make

Install the package:

make install

64Bit

If you have gcc4.3, apply this patch :

patch -Np1 -i ../libofx-0.9.0-gcc4.3-1.patch

Compile the package:

CC="gcc ${BUILD64}" CXX="g++ ${BUILD64}" \
PKG_CONFIG_PATH="$PKG_CONFIG_PATH64}" USE_ARCH=64 \
./configure --prefix=/usr --libdir=/usr/lib64 \
    --with-opensp-libs=/usr/lib64 &&
make

Install the package:

make install

Contents

Installed Programs: ofxconnect, ofxdump, ofx2qif
Installed Libraries: libofx.{a,la,so}
Installed Directories: /usr/include/libofx, /usr/share/doc/libofx, /usr/share/libofx
Personal tools